Lab 4 - Data Acquisition

Report
A short report is due at 8:00 AM on the Thursday of the next week of classes after you complete this lab. This short report does NOT need to follow the formal report format described in the ME 360 course manual. “Screen shots” from the four exercises included in this lab are required along with other items specifically indicated in this handout. When you have completed each of the four exercises, do the following:

1. Maximize the front panel of the LabVIEW VI (virtual instrument).
2. Press “Alt” and “Print Screen” simultaneously to store a “screen shot” into the clipboard.
3. Open PowerPoint and paste the “screen shot” onto a page (Edit>>Paste). Use a landscape view to match the orientation of the screen to the page. The pasted image should cover most of the page.
4. Return to LabVIEW and maximize the wiring diagram panel. Repeat steps #2 and #3 to paste an image of the wiring diagram into PowerPoint.
5. When you have completed all four of the LabVIEW exercises you should have an 8 page PowerPoint presentation that can be saved and printed (outside the 360 lab).

Introduction
Many of the personal computers located in the ME laboratories are equipped electronic circuits that can capture and collect data. Such configurations are called “data acquisition systems”.

The ME 360 labs use National Instruments PCI-MIO-16E-4 data acquisition boards and LabVIEW software. The purpose of Lab #3 is to give you some experience using this software to accomplish typical data collection tasks. This lab will not make you a LabVIEW “expert,” but will provide a foundation upon which you can build in subsequent electives and project courses.
Exercise #4.1 - Opening and Operating a Virtual Instrument

This part of the laboratory will begin by executing a Virtual Instrument (VI) program, Signal Generation and Processing.vi. It will demonstrate the various types of the input signals that are available, how to change their frequencies and the filtering options.

1. Select Start»Programs»National Instruments»LabVIEW 6.1»LabVIEW to launch LabVIEW. The LabVIEW dialog box appears.

2. Click the Search Examples button. Next, select Demonstrations and then the Analysis option. They will appear as hyper-linked text (much like a link on a web-page.)

3. With the Browse Tab choose Analyzing and Processing Signals, then Signal Processing, then Signal Generation and Processing.vi.

This will open the Signal Generation and Processing VI Front Panel.

Note You also can open the VI by clicking the Open VI button and navigating to labview\examples\apps\demos.llb\Signal Generation and Processing.vi.

Front Panel

4. Click the Run button on the toolbar, to run this VI. This VI determines the result of filtering and windowing a generated signal. This example also displays the power spectrum for the generated signal. The resulting Signal tracings are displayed in the graphs on the front panel, as shown in the following figure.
5. Use the Operating tool, a pointing finger button, to change the Input Signal and the Signal Processing, to use the increment or decrement arrows on the control, and to drag the pointer to a desired Frequency.

6. Click the **Run** button to run the VI again. Then, try adjusting the other controls on the panel to see what changes occur.

**Block Diagram**

7. In order to do this step, the VI must not be running, so stop it first by selecting the red “STOP” button with the mouse, or typing the F4 key. Then select **Window»Show Diagram** or press the <Ctrl-E> keys to display the block diagram for the Signal Generation and Processing VI. This block diagram contains several of the basic block diagram elements, including subVIs, functions, and structures, whose operations will be clarified later in this course.

8. Select **Window»Show Panel** or press the <Ctrl-E> keys to return to the Front Panel.

9. Press the **More Info…** button or [F5] to read more about the analysis functions.

   **Report** - Create a list of at least 10 additional analysis functions available in LabVIEW. This list is to be added to your PowerPoint file.

10. Press the **Stop** button or [F4] to stop the VI.

   **Report** - Create a screen shot of the **Signal Generation and Processing VI panel** (not control diagram). Add this screen shot to your PowerPoint file.

**End of Exercise #4.1**

*Note – This LabVIEW exercise was downloaded from the National Instruments website. It was developed to assist faculty and students that want to both learn and use National Instruments products. Their assistance in making these resources available is greatly appreciated.*
Exercise #4.2 - Build a VI

This part of the exercise demonstrates how to create a VI that takes a number representing degrees Celsius and converts it to a number representing degrees Fahrenheit. It is accomplished by completing the steps that follow.

To clarify some wiring illustrations, a mouse icon with a labeled arrow will be used. The arrow will indicate where to click and the number on the arrow indicates how many times to click.

Front Panel

1. Select File » New to open a new front panel.

2. (Optional) Select Window » Tile Left and Right to display the front panel and block diagram side by side. Select Window » Tile Up and Down to display the front panel above the block diagram.

3. Create a numeric digital control. You will use this control to enter the value for degrees Centigrade.
   a. Select the digital control on the Controls » Numeric palette. If the Controls palette is not visible, right-click an open area on the front panel to display it.
   b. Move the control to the front panel and click to place the control.
   c. Type deg C inside the label and click outside the label or click the Enter button on the toolbar. If you do not type the name immediately, LabVIEW will use a default label. You can edit a label at any time by using the Labeling tool.

4. Create a numeric digital indicator. You will use this indicator to display the value for degrees Fahrenheit.
   a. Select the digital indicator on the Controls » Numeric palette.
   b. Move the indicator to the front panel and click to place the indicator.
   c. Type deg F inside the label and click outside the label or click the Enter button.

LabVIEW automatically creates corresponding control and indicator terminals on the block diagram. The terminals represent the data type of the control or indicator. For example, a DBL terminal represents a double-precision, floating-point numeric control or indicator.
Block Diagram

5. Display the block diagram by clicking it or by selecting `Window»Show Diagram`.

**Note** - Control terminals have a thicker border than indicator terminals.

```
  1.80
  32.0
```

6. Select the Multiply and Add functions on the `Functions»Numeric` palette and place them on the block diagram. If the `Functions` palette is not visible, right-click an open area on the block diagram to display it.

7. Select the numeric constant on the `Functions»Numeric` palette and place two of them on the block diagram. When you first place the numeric constant, it is highlighted so you can type a value.

8. Type `1.8` in one constant and `32.0` in the other.

If you moved the constants before you typed a value, use the Labeling tool to enter the values.

9. Use the Wiring tool (Choose: `Window>>Tools` palette) to wire the icons as shown in the previous block diagram.
   - To wire from one terminal to another, use the Wiring tool to click the first terminal, move the tool to the second terminal, and click the second terminal, as shown in the following illustration. You can start wiring at either terminal.

```
  1.80
  32.0
```
   - You can bend a wire by clicking to tack the wire down and moving the cursor in a perpendicular direction. Press the spacebar to toggle the wire direction.
   - To identify terminals on the nodes, right-click the Multiply and Add functions and select `Visible Items»Terminals` from the shortcut menu to display the connector pane. Return to the icons after wiring by right-clicking the functions and selecting `Visible Items»Terminals` from the shortcut menu to remove the checkmark.
   - When you move the Wiring tool over a terminal, the terminal area blinks, indicating that clicking will connect the wire to that terminal and a tip strip appears, listing the name of the terminal.
• To cancel a wire you started, press the <Esc> key, right-click, or click the source terminal.

10. Display the front panel by clicking it or by selecting **Window»Show Panel**.

11. Save the VI because you will use this VI later in the course.
   a. Select **File»Save**.
   b. Navigate to c:\exercises\LV Basics I.

**Note** Save all the VIs you edit in this course in directory c:\exercises\LV Basics I.

   c. Type **Convert C to F.vi** in the dialog box.
   d. Click the **Save** button.

12. Enter a number in the digital control and run the VI.
   a. Use the Operating tool or the Labeling tool to double-click the digital control and type a new number.
   b. Click the **Run** button to run the VI.
   c. Try several different numbers and run the VI again.

13. Select **File»Close** to close the Convert C to F VI.

**Report** - •⇒Create screen shots of **both the Front Panel and the Block Diagram**. Add these screen shots to your PowerPoint file.

End of Exercise #4.2

**Note** – This LabVIEW exercise was downloaded from the National Instruments website. It was developed to assist faculty and students that want to both learn and use National Instruments products. Their assistance in making these resources available is greatly appreciated.
Exercise #4.3 - Data Acquisition

In this part of the exercise you will use LabVIEW to collect analog voltage data from a potentiometer and convert the reading to an angle in degrees. A rotary potentiometer will be wired to the National Instruments CB-68LP board by your lab monitor.

Front Panel

Follow the steps listed below to create the front panel shown below. Do not be concerned with exact placement of the items on the panel.

1. Start LabVIEW and click **New VI** to open a new front panel. If LabVIEW is already open, then click **File>>New** to open a new front panel.

2. Bring up the Controls palette (**Window>>Show Controls** palette). Click the “push pin” in the upper left hand corner if you want to keep this palette visible.

3. Select the Numeric palette, from the Controls palette.

4. Select **Digital Indicator**, and drag one onto the front panel. Label this first indicator “Voltage.”

5. Select **Digital Control**, and drag one onto the front panel. Label this first control “Offset.”

6. Select another **Digital Control** and drag it onto the front panel. Label this second control “Gain.”
7. Switch to the diagram (Window>>Show Diagram) and bring up the Functions palette (Window>>Show Functions palette)

8. Select the Data Acquisition palette, , and select Analog Input, .

9. Select the AI Sample Channel icon (icon will say AI ONE PT) from the Analog Input set and drag it onto the wiring diagram.

10. The AI Sample Channel VI requires two inputs – one to select the device and another to select the channel. Return to the Data Acquisition palette, select the DAQ Channel Name Constant, , and drag it to the left side of the AI ONE PT icon.

11. Return to the Functions palette and select the Numeric palette. Select the Numeric Constant icon, , and drag it near the upper left-hand corner of the AI ONE PT icon.

12. Select “Yellow” from the drop-down box in the DAQ Channel Name Constant (this selects channel 0 which uses the yellow/black wires) and change the value in the Numeric Constant icon to 1 (which selects device #1 – the NI data acquisition board). You must have the “hand” icon in order to do this.

13. Wire the Numeric Constant icon to the top input on the left side of the AI ONE PT icon. Wire the DAQ Channel Name Constant icon to the second input on the left side AI ONE PT icon. Wire the single output from the right side of the AI ONE PT icon to the input on the left side of the Digital Indicator labeled Voltage as shown below.
14. Click the **Run Continuously** icon, and move the pointer on the potentiometer. You should see the voltage values changing in the front panel. Click the **Stop** icon, to stop the execution of the VI.

15. Return to the **Functions** palette and click on the **Numeric** panel. Drag an numerical **Add** icon, and a Multiply icon, to the wiring diagram. Use the wiring tool to add the **Voltage** value to the **Offset** value and multiply the result by the **Gain** value.

16. Return to the front panel and bring up the **Controls>>Numeric** palette. Drag a **Gauge**, onto the front panel. Use the **Edit Tool**, to change the default value on the gauge from 10 to 180. The remaining values on the gauge will be automatically renumbered. The front panel should look something like this:

17. Return to the diagram and wire the output from the **Multiply** icon to the input of the gauge.
18. Return to the front panel and click the **Run Continuously** icon. Select values for **Offset** and **Gain** such that the on-screen gauge closely matches the physical position of the potentiometer.

19. Demonstrate the operation of your VI to the lab monitor once you have selected an offset and gain that gives satisfactory results.

**Report** - Create screen shots of **both the Front Panel and the Block Diagram**.

*Add these screen shots to your PowerPoint file.*

**End of Exercise #4.3**
Exercise #4.4 - Use a Loop to Retrieve Data

Use a “While Loop” and a waveform chart to build a VI that demonstrates software timing.

Front Panel
1. Open a new VI.
2. You will build the following front panel in this step:

   - Select the horizontal pointer slide on the Controls»Numeric palette and place it on the front panel. You will use the slide to change the software timing.
   - Type millisecond delay inside the label and click outside the label or click the Enter button on the toolbar, shown at left.
   - Select a waveform chart (not graph!) on the Controls»Graph palette and place it on the front panel. The waveform chart will display the data in real time.
   - Type Value History inside the label and click outside the label or click the Enter button.
   - The waveform chart legend labels the plot Plot 0. Use the Labeling tool to triple-click Plot 0 in the chart legend, type Value, and click outside the label or click the Enter button to re-label the legend.
   - Change +10.0 in the y-axis to +2.0 and change -10.00 to 0.00.
   - Label the y-axis Value and the x-axis Time (sec).
   - Select the Stop button from Controls»Boolean palette and place it on the front panel.
Block Diagram

3. Select **Window»Show Diagram** to display the block diagram.
4. Add the **Analog Input One Point** block, the **Numerical Constant** block, and the **DAQ Channel Name Constant** to the diagram as shown below...DO YOU NEED THE DELAY AND WAVEFORM CHART AS WELL???
Note that you can “copy & paste” this set of blocks from the VI you created in Lab #4.3.
5. Enclose the existing elements, which are shown in the following block diagram, within a **While Loop**.

![Block Diagram Image]

a. Select the **While Loop** on the **Functions»Structures** palette.
b. Click and drag a selection rectangle around all the existing elements.
c. Use the Positioning tool to resize the loop, if necessary.
d. Right click on the **While Loop** and check the option labeled **Stop if True**.

6. SHOULD THIS COME BEFORE THE WHILE LOOP ENCLOSURE?? I THINK NOT... FROM STEP 8 BELOW... Wire the block diagram objects as shown in the previous block diagram.
7. Display the front panel by clicking it or by selecting **Window»Show Panel**.
8. Run the VI.
The section of the block diagram within the While Loop border, or subdiagram, executes until the specified condition is TRUE. For example, while the STOP button is not pressed, the VI returns a new number and displays it on the waveform chart.
9. Click the STOP button to stop the acquisition. The condition is FALSE, and the loop stops executing.
10. Format and customize the X and Y scales of the waveform chart.
   a. Right-click the chart and select **Y Scale»Formatting** from the shortcut menu. The following dialog box appears.
   b. Click the **Scale Style** icon and select different styles for the y-axis. You also can select different mapping modes, grid options, scaling factors, and formats and precisions.
   c. Select the options shown in the previous dialog box and click the **OK** button.
11. Right-click the waveform chart and select **Data Operations»Clear Chart** from the shortcut menu to clear the display buffer and reset the waveform chart. If the VI is running, you can select **Clear Chart** from the shortcut menu.

**Adding Timing**

When this VI runs, the While Loop executes as quickly as possible. Complete the following steps to take data at certain intervals, such as once every half-second, as shown in the following block diagram.  [WHAT BLOCK DIAGRAM?]

a. Place the **Wait Until Next ms Multiple** function located on the **Functions»Time & Dialog** palette. This function makes sure that each iteration occurs every half-second (500 ms).

b. Connect the millisecond delay control to the **Wait Until Next Millisecond Multiple**. This will allow you to adjust the speed of the execution from the pointer slide on the front panel.

12. Save the VI.

13. Run the VI.

14. Try different values for the millisecond delay and run the VI again. Notice how this effects the speed of the number generation and display.

15. Close the VI.

**Report** - Create screen shots of both the **Front Panel** and the **Block Diagram**. Add these screen shots to your PowerPoint file.

**End of Exercise #4.4**